1. The Turbo Forums - The discussion board for both hard core and beginner turbocharged vehicle enthusiasts. Covering everything from stock turbocharger cars, seriously fast drag racers, boats, motorcycles, and daily driver modified turbo cars and trucks.
    To start posting in our forums, and comment on articles and blogs please

    IF YOU ARE AN EXISTING MEMBER: You can retrieve your a password for your account here: click here.

4.8 GT45 TH400 Sloppy Build - slower than expected

Discussion in 'Dyno Results and Track Times Forum' started by 20112011Cummins, Jul 3, 2020.

  1. 20112011Cummins

    Joined:
    Jul 4, 2014
    Hello all. I've been lurking a long time and finally have a reason to post up. My build finally came together and sadly its a litter slower than expected.

    Details (basically sloppy don't BS me clone):
    1970 Cutlass
    4.8 sbe
    Microsquirt
    sloppy stage 2 cam
    Pac-1218 springs
    80# decapped injectors, flowed and tested
    Homemade methanol injection, 20# nozzle
    Hughes budget 3000rpm converter
    stock rebuild th400 with Transgo 400-3 full manual kit (shifts take a long time? drop 13-1500 rpm though)
    3.23 gears
    275-50-15 mickey thompson ET streets

    Race weight without driver 3250 lbs.

    So far it has been street tuned by me, starting with the sloppy base tune, and is running 10-11lb boost.

    First track outing, best time of 4 passes:
    2.22 60 ft
    8.75 1/8th mile @ 85.0 mph
    13.38 1/4 mile @ 105.9mph

    Timing is about 16-17 degrees at 11psi boost. AFRs are 11.0-11.5 in boost. Launch was on the footbrake and about 3000rpm and 4ish psi.

    I uploaded a log file and an image of the best pass. Maybe i'm dreaming but I expected something like 420 rwhp and 120mph trap speeds based on Matt's don't BS me dyno videos and internet calculators.

    I'm not sure where to start with this. Any advise would be great! I'll work on uploading a video and linking it.

    Thanks!

    Sluggish 0-100 run.jpg #ad
     

    Attached Files:

  2. Disney Lincoln

    Joined:
    Feb 14, 2003
    First thoughts are...

    1. What turbo? Cam? Intake?
    2. That converter... Probably not helping anything.
    3. Might need some more gear
    4. Definitely needs more boost
     
  3. 20112011Cummins

    Joined:
    Jul 4, 2014
    Vs racing gt45. Gen 3 truck intake, sloppy stage 2 cam (228/230)

    I agree on the rest. I dont have much experience with converters so that's probably a starting point.

    This car has a oddball rear end so getting different gears for it is probably not going to happen until I can get a 9" or 12 bolt for it.
     
  4. 20112011Cummins

    Joined:
    Jul 4, 2014
    I did manage to check a couple things.

    First I verified the base timing by checking TDC and setting the offset in megasquirt. It was right, so my timing was good.

    I also checked the vacuum modulator and put a pressure gauge on the th400. Pressures seem in line with what I've read they should be with modulator hooked and unhooked.

    Still stumped as to why it's sluggish. I'll work on getting the video posted.
     
  5. Mnlx

    Joined:
    Sep 20, 2009
    Can you post your timing table? I also agree you need more boost. Did you happen to degree the cam?
     
  6. 20112011Cummins

    Joined:
    Jul 4, 2014
    Ignition table attached. I tweaked the idle timing but the rest is from the Sloppy base tune.

    Cam was just aligned dot to dot, not degreed in.

    I'm happy to turn the boost up but I was expecting a bit more at 11psi. The mph/time I'm running suggests about 280 whp, which is about what I would've expected N/A. This is referencing youtube dyno videos of similar combos for what that's worth.

    ignition table.jpg #ad
     
  7. Mnlx

    Joined:
    Sep 20, 2009
    Factory timing set? I'm with you on expecting more out of it. I'm surprised it can only manage a 2.2 60' leaving on 4psi.
     
  8. 20112011Cummins

    Joined:
    Jul 4, 2014
    Yup, factory everything. Chain looked decent from what I remember.

    I had log files from the runs, and the wife took a video of one so I tried out a racerender video.



    I'm at a loss with this thing. A guy in this same section had better times with 6psi and 2.56 gears?!
     
  9. Disney Lincoln

    Joined:
    Feb 14, 2003
    What does your exhaust consist of? Agree that looked really sluggish and didn't sound like it was OK with making RPM.
     
  10. Disney Lincoln

    Joined:
    Feb 14, 2003
    And have you done a plug reading on a fresh plug?
     
  11. 20112011Cummins

    Joined:
    Jul 4, 2014
    Exhaust is 4" straight pipe to axle.

    I haven't done a reading on a fresh set of plugs. I did pull the set out just to see and all 8 looked same and rich. They had street miles on them though.

    I may try to schedule time on a local dyno and see what happens.
     
  12. patl

    Joined:
    Jun 6, 2009
    We're bout the same weight, see my et in sig. Stock, shifting @ 5300rpm.
    I think you gotta have some gear with that small motor.
     
  13. 20112011Cummins

    Joined:
    Jul 4, 2014
    You were almost a second faster in the 8th and that's running N/A? What gear and what tire?

    I ordered a compression tester, depending on what that tells me I'm ready to tear this thing all the way down and see what I find.
     
  14. Mnlx

    Joined:
    Sep 20, 2009
    You're much better off to do a leak down test if you can. Compression tests tell you if you have big issues, but leak down will give you much more info.
     
  15. 20112011Cummins

    Joined:
    Jul 4, 2014
    Seems reasonable to me. I ordered one, it will be here Thursday. I'll update once I check it.

    I had a sticky wastegate a while ago that caused some high boost at low RPMs. Hit boost cut at like 19psi I think. It makes me wonder if I hurt it somehow.

    It has no odd symptoms that I can tell. Great oil pressure, no smoke anytime, etc.
     
  16. Mnlx

    Joined:
    Sep 20, 2009
    Pistons are pretty fragile if they see detonation, maybe loosened a ring land or two. Compression test would hopefully show that if it's the case.
     
  17. Disney Lincoln

    Joined:
    Feb 14, 2003
    I've broke a few LS pistons. They smoke like the dickens when you break one.
     
    55Chevy likes this.
  18. BBR

    Joined:
    Jan 3, 2013
    How does it run n/a?
     
  19. 20112011Cummins

    Joined:
    Jul 4, 2014
    I can imagine so!

    I'm not sure. Never ran it without turbo setup. I may do just that to try and rule some things out.
     
  20. patl

    Joined:
    Jun 6, 2009
    60ft is what your seeing; mine 1.56 vs your 2.22.
    4.56 on slicks, on the brake. Still runs 8.00's FB.
     
Loading...
Similar Topics - GT45 TH400 Sloppy Forum Date
Ebay/Amazon GT45 prices Dyno Results and Track Times Forum Mar 24, 2020
ebay gt45 turbos on nova Dyno Results and Track Times Forum Nov 22, 2018
Jy l31 gt45 turbo new dyno sesion Dyno Results and Track Times Forum Oct 1, 2015
Tags:
Loading...
bridal-shoal